Back to overview
Resolved
Billing Maintenance
Jun 22, 2026 at 12:00am UTC
–
Jun 22, 2026 at 1:00am UTC
Affected services
panel.allay-hosting.com
Resolved
Jun 22, 2026 at 1:00am UTC
Maintenance ended
Affected services
Created
Jun 22, 2026 at 12:00am UTC
The Billing Panel will undergo scheduled maintenance during this period.
All servers and game services will remain fully online and operational. However, access to the Billing Panel, including server renewals and billing-related actions, will be temporarily unavailable.
The Game Panel is not affected and will remain fully accessible throughout the maintenance window.
Affected services