Back to overview
Resolved

Temporary Service Disruption

Jul 2, 2026 at 1:30pm UTC
Affected services
euc-040
euc-060
euc-070
kvm-euc-010
kvm-euc-020

Resolved
Jul 2, 2026 at 11:00pm UTC

Game nodes and KVM servers are now back online and accessible.

Please note that all customer IP addresses have changed. Additionally, ports for purchased 19132 and 25565 upsells have also been updated.

We are currently experiencing intermittent issues with our DDoS protection. To prioritize service availability, our current focus is on maintaining stable uptime while we continue working on the remaining infrastructure. As an alternative, customers who require uninterrupted DDoS protection may temporarily use https://neoprotect.net/ or https://tcpshield.com/.

More information and further updates will be shared as soon as possible.

Updated
Jul 2, 2026 at 9:30pm UTC

The cause of the service disruption has been identified, and a fix is currently being deployed. Service should be available again soon. Thank you for your patience and understanding.

Created
Jul 2, 2026 at 1:30pm UTC

We are currently experiencing a service disruption affecting some users. Our team is investigating the issue and working to restore normal service as quickly as possible. We apologize for the inconvenience and appreciate your patience.